Pi-Hole auf einer Synology NAS installieren

  • Hallo und Willkommen sweckster ,


    wenn der DNS-Dienst der Synology nicht installiert ist, kann der Dienst der auf Port 53 lauscht, "gekillt" werden. Am besten auf der Synology mit SSH verbinden und anschließend mit netstat -tulpen | grep 53 kontrollieren und sich die PID des Dienstes merken. Jetzt mit kill -9 <PID> den Dienst beenden. Sollte es jetzt nicht funktionieren, den Ordner dnsmasq.d-configs auf berechtigungen prüfen in der FileStation.


    :::Testing pihole-FTL DNS: sudo: unable to resolve host pihole-pihole1: Name or Service not known.

    Kann behoben werden, indem man in die /etc/hosts die 127.0.0.1 hinzufügt. Der Fehler kann aber auch ignoriert werden, da es den Nutzen von PiHole nicht mindert.

  • Hi!

    Super wie zügig das hier funktioniert! 8)

    Nach dem Beenden/Deinstallieren des für meine Heimnutzungszwecke überdimensionierten DNS-Servers auf der Synology ist Port 53 schonmal kein Problem mehr... Jedoch scheint PiHole der Link auf die IP meiner DS716 nicht ganz zu gefallen.
    Belasse ich den Eintrag SERVERIP in ENV bei 0.0.0.0 startet PiHole zwar - Nutzen kann ich aber noch keinen ziehen.
    Beim Ändern auf mein 192.268.2.222 gibts dann folgende Quittung:



    Hierzu vielleicht noch eine Idee?

    IM Netzwerk-Settings-Dialog meiner Synology steht im Bereich Gateway zunächst nichts Spezielles - Den würde ich aber auf die voranstehende Fritzbox lauten lassen.
    DNS Server ist nicht manuell konfiguriert - Hat das noch etwas mit den Settings hier zu tun`?


    Grüße!

  • Hierzu vielleicht noch eine Idee?

    IM Netzwerk-Settings-Dialog meiner Synology steht im Bereich Gateway zunächst nichts Spezielles - Den würde ich aber auf die voranstehende Fritzbox lauten lassen.
    DNS Server ist nicht manuell konfiguriert - Hat das noch etwas mit den Settings hier zu tun`?

    Lösche den Docker-Container nochmal, starte die NAS neu und versuche es erneut. Ich glaube deine NAS hat sich verschluckt :/

  • Lösche den Docker-Container nochmal, starte die NAS neu und versuche es erneut. Ich glaube deine NAS hat sich verschluckt :/

    Hi!
    Hatte schon fast aufgegeben... Aber siehe da: Der Tipp hat echt geholfen. Wobei es für mich immer kein schönes Resultat ist, wenn das einfache AUS-EIN-Prinzip Abhilfe schafft. Dazugelernt hab ich da nicht wirklich was - Schwamm drüber: Nu tut's und ich konfiguriere mal fleißig :saint: !

    Danke vielmals für die doch echt immer zeitlich-sportliche Unterstützung!

    Grüße!

  • Hallo und Willkommen Waldlaeufer


    leider unterstützt Synology – Docker nur auf NAS-Systemen mit einem Intel CPU. Es gibt natürlich Möglichkeiten, dies auszuhebeln. Ein Beispiel hierfür findet sich auch auf Google.


    How to install Docker on an unsupported Synology NAS (updated 2020)
    Synology has limited Docker availability in the package manager to only some select models (models and links updated 12/21/2020) 21 series:DS1821+, DS1621xs+,…
    tylermade.net


    Da ich aber nicht weiß, wie stabil sich diese Systeme dann verhalten, rate ich dazu, dies nicht zu nutzen. Eine kostengünstige alternative, wäre hier die Anschaffung eines Raspberry Pi.

  • Moin Moin,

    und ebenfalls vielen Dank für das tolle Tutorial. funzt bei mir soweit sehr gut. ich musste den Port 8080 in der FF freigeben, damit ich auf die Admin Oberfläche komme, aber das war schnell gefunden.

    Aber wie kann ich den nun meinen PC über die PI-Hole laufen lassen? Mit dem PiHole meiner Rasberry PI habe ich die IP der RasPi genommen, als DNS Server. Das funzt aber bei dem Synology irgendwie nicht. Gibts dort noch etwas besonderes zu beachten, um dann auch über die NAS PiHole zu surfen?


    Edit: Ich habe gerade herausgefunden, das es mit der Firewall zusammenhängt. Den Port 8081 (ich hatte nicht 8080 genommen) habe ich via TCP in der Firewall freigegeben, jedoch kann ich weiterhin keine Webseiten über meinen PC aufrufen. Erst wenn ich die FW deaktiviere klappt es.

    Hat jemand einen Tipp, welchen Port oder Dienst ich noch freigeben muß?


    Edit2: Port 53 auf Alle und es funzt wunderbar!


    Vielen Dank,

    deltapapa

  • Hallo,


    zunächst einmal ein tolles und verständliches Tutorial. :thumbup:

    Ich habe das jetzt auf meiner DS installiert, und das Pi-Hole interface aufgerufen. Allerdings wird mir hier angezeigt, dass die Netzwerk Schnittstelle "eth0" derzeit nicht existiert (siehe Screenshot).

    Es funktioniert leider auch nicht, in den QueryLog wird nichts gefunden, obwohl ich im Router (FritzBox) die Nameserver auf die IP der Diskstation eingestellt habe!

    Habe ich was übersehen, bzw. wie kann ich das beheben?


    PS: auf der Diskstation ist nicht der "DNS Server" installiert, das läuft alles über die FritzBox!

  • Wenn unter der aktuellen Docker Version der Pihole Container immer neu startet, hilft vielleicht das setzen der Environment Variable DNSMASQ_USER:root


    Zum Tutorial: ich würde nicht den häufig verwendeten Port 8080 verwenden. Den nutzen viele weitere Programme. Ich selbst habe mit für den wenig originellen Port 8888 entschieden.

    M.E. gehört zu einem guten bzw. vollständigen Tutorial auch die Einstellungen auf dem Pihole und vielleicht sogar auf derm deutschen Quasi-Standard ‚Fritz Box‘

  • Hallo rspille ,

    Zum Tutorial: ich würde nicht den häufig verwendeten Port 8080 verwenden. Den nutzen viele weitere Programme. Ich selbst habe mit für den wenig originellen Port 8888 entschieden.

    M.E. gehört zu einem guten bzw. vollständigen Tutorial auch die Einstellungen auf dem Pihole und vielleicht sogar auf derm deutschen Quasi-Standard ‚Fritz Box‘

    Natürlich werden auch von anderen Diensten, die im eigenen Netzwerk gehostet werden, Ports verwendet. Aber ich stimme zu, dass der Port 8080 ein beliebter Port ist. Ich als Ersteller des Tutorials, kann jedoch nicht wissen, welche Ports im privaten Netzwerk belegt sind. Des Weiteren sehe ich die Fritz!Box von AVM nicht als deutschen Standard, da die meisten privaten Leute immer noch einen Router des Providers zu Hause stehen haben. Ich kann natürlich noch ergänzend erwähnen in der Anleitung, dass die IP des Containers als Lokaler DNS angegeben werden muss.

  • Hallo, bin zwar neu hier aber nichts desto Trotz kann ich eventuell auch etwas sinnvolles beitragen...

    Ich habe nach der hier beschriebenen Anleitung den pihole installiert, was auch anstandslos funktioniert hat. Nur funktionierte bei mir kein Internet mit dem pihole als DNS.

    Nach einigem fehlersuchen bin ich dann fündig geworden:

    Nach der Standardinstallation wie hier beschrieben, sah meine Standardkonfiguration unter "Settings/DNS" folgendermaßen aus:




    Sie muß aber so ausschauen:



    Nach dieser Änderung funktionierte alles wunderbar.

  • Hallo und Willkommen Jens1976


    ja das ist korrekt. Die Anleitung bezieht sich darauf, dass nicht der DNS des Pihole genutzt wird. Eventuell wäre dieses Tutorial für Sie auch interessant, Unbound geht nämlich auch mit Pi-hole :)


    • Gäste Informationen

    Hallo, gefällt dir der Thread, willst du was dazu schreiben, dann melde dich bitte an.


    Hast du noch kein Benutzerkonto, dann bitte registriere dich, nach der Freischaltung kannst du das Forum uneingeschränkt nutzen.